読者です 読者をやめる 読者になる 読者になる

console.lealog();

@leader22のWeb系に関する勉強めもブログですのだ

Marionette使っててgrunt-contrib-requirejsでBackbone is not defined

Grunt Backbone.js Marionette.js

っていうエラーになる謎の現象に遭遇してまして・・。

原因はよーわかってません。
まあ検索するとそれなりに出てくるので、意外に仲間はいるらしい。

回避方法は続きから。

AMD対応版を使う

以下、ソースへのリンク。

これらをDLして、pathsに書く。

このように。

// ...
paths: {
  'underscore':          'vendor/underscore',
  'jquery':              'vendor/jquery',
  'backbone':            'vendor/backbone',
  'backbone.wreqr':      'vendor/backbone.wreqr',
  'backbone.babysitter': 'vendor/backbone.babysitter',
  'marionette':          'vendor/backbone.marionette'
},
// ...

以上!

そうすればそもそもshimも書かなくていいし、よくわからん事故に巻き込まれることもない。
BackboneもちゃんとAMD対応されてるバージョンやし、よくわからんなー。